Jump to content
Rakly3

Igfx Intel + AMD GPU's

Recommended Posts

If people run into problems with this setup combination [title] you can use nsgminer with these commands in a .bat file

cgminer --neoscrypt --no-nvml --no-submit-stale --gpu-platform 1 -o http://127.0.0.1:8396/wallet/game.dat -u USER -p PASSWORD -I 8

if you use nsgminer you have to change that frm cgminer ofcourse.
-I will be different depending on your card, 8 is the default setting.
gpu-platform 1 is ONLY for systems with a Intel Igfx.

If you also have nvidea cards in the setup, remove the "-no-nvml" command. This command skips nvidea detection.
If the miner closes by itself you can add another line at the end with just the word pause , that way you can read the error.

Edited by Rakly3
added platform 1 to launch commands
  • Like 1

Share this post


Link to post
Share on other sites

Have you been getting  blocks with your AMD setup? nsgminer on my AMD rigs have reported at least 3-4 blocks found, but no CHI is awarded to me in the Electron wallet.

 

CCminer and my Nvidia rigs don't have this problem, so my AMD rigs are back to ETH/XMR mining for now.

Edited by ratchet5000

Share this post


Link to post
Share on other sites
3 hours ago, ratchet5000 said:

Have you been getting  blocks with your AMD setup? nsgminer on my AMD rigs have reported at least 3-4 blocks found, but no CHI is awarded to me in the Electron wallet.

 

CCminer and my Nvidia rigs don't have this problem, so my AMD rigs are back to ETH/XMR mining for now.

Were the blocks just not matured yet? It takes a number of blocks before they're available. I forget the number at the moment. 

Also, did you check whether you were looking at your vault or game wallet? There are 2 wallets in the XAYA Electron wallet. 

Share this post


Link to post
Share on other sites
7 hours ago, Ryan said:

Were the blocks just not matured yet? It takes a number of blocks before they're available. I forget the number at the moment. 

Also, did you check whether you were looking at your vault or game wallet? There are 2 wallets in the XAYA Electron wallet. 

They never show up. I originally thought that maybe I was unlucky enough to get stale blocks, but 10-15 blocks found reported by the nsgminer, but nothing shows up in transactions in Electron, vault or game wallets, and only on my AMD rigs. The wallets associated with my Nvidia rigs are filling up with CHI, so I know about how the transactions panel in the game wallet should look.

 

It might just be poor support from the many neoscrypt mining programs for solo mining with AMD, what's the progress with mining pools for CHI? I think I saw someone say they wanted to start one on Telegram the other day.

 

 

Share this post


Link to post
Share on other sites

are you running the daemon?

if so, run with -debug=1

mine a block on testnet

and see what it says in debug.log

 

let me know if you need more help with that

Share this post


Link to post
Share on other sites
20 hours ago, snailbrain said:

are you running the daemon?

if so, run with -debug=1

mine a block on testnet

and see what it says in debug.log

 

let me know if you need more help with that

No I was using nsgminer  for AMD (ccminer for Nvidia) along with cookie as login info from electron wallet. I'm new to mining neoscrypt, CHI is my first.

I'm assuming I have to input something into the console in electron or command prompt to the directory to mine that way? I've called getmininginfo() before.

Share this post


Link to post
Share on other sites
On 7/13/2018 at 9:33 PM, Rakly3 said:

If people run into problems with this setup combination [title] you can use nsgminer with these commands in a .bat file

set GPU_FORCE_64BIT_PTR=1
set GPU_MAX_HEAP_SIZE=100
set GPU_USE_SYNC_OBJECTS=1
set GPU_MAX_ALLOC_PERCENT=100
set GPU_SINGLE_ALLOC_PERCENT=100
nsgminer --neoscrypt --no-nvml --no-submit-stale -o http://127.0.0.1:8396/wallet/game.dat -u USER -p PASSWORD -I 16

If you also have nvidea cards in the setup, remove the "-no-nvml" command. This command skips nvidea detection.
If the miner closes by itself you can add another line at the end with just the word pause , that way you can read the error.

Hi,

I'm new to mining.

I have an AMD video card along with intel GPU (iGPU).

When I launch nsgminer with the command in the post above, I'm getting these errors:

 

Cattura.PNG.a637b664a83da5b3df25533f404284f7.PNG

 

Searching with google it seems to be a problem related to iGPU.

So I tried the following command for GPU mapping:

nsgminer -n option

and output is this:

Cattura.PNG.222fe0db84b5f9dcdc46bfaa532421d9.PNG

As we can see in this screenshot, my AMD video card is platform 0.

So added --gpu-platform 0 to the command for mining and this is the resulting command:

nsgminer --neoscrypt --no-nvml --no-submit-stale -o http://127.0.0.1:8396/wallet/game.dat -u __cookie__ -p PASSWORD -I 16 --gpu-platform 0 --no-adl

but it's not working and no error on output.

With debugging option enabled I get this:

Cattura.thumb.PNG.04045c896efb3f1d1039aeca22e24d9e.PNG

Can anybody help me?

Share this post


Link to post
Share on other sites

when you specify the user and password

try with -u <rpcuser> -p <rpcpassword ... in stead of -O

also run the daemon with -debug=1

and check what it is saying in there

Share this post


Link to post
Share on other sites
31 minutes ago, snailbrain said:

when you specify the user and password

try with -u <rpcuser> -p <rpcpassword ... in stead of -O

also run the daemon with -debug=1

and check what it is saying in there

Yep I'm not using -O for authentication.

I'm using -u for user and -p for password.

This is the command I'm using:

nsgminer --neoscrypt --no-nvml --no-submit-stale -o http://127.0.0.1:8396/wallet/game.dat -u __cookie__ -p PASSWORD -I 16 --gpu-platform 0 --no-adl

Where should I put -debug=1?

Thanks for your help

Share this post


Link to post
Share on other sites

you will need to edit the .bat files in the xaya install dir in program files and stick in somewhere in there (there is 2 in each .bat file).

or you could start the daemon separately and not use the electron wallet.

 

Share this post


Link to post
Share on other sites
14 minutes ago, snailbrain said:

you will need to edit the .bat files in the xaya install dir in program files and stick in somewhere in there (there is 2 in each .bat file).

or you could start the daemon separately and not use the electron wallet.
 

In the attachment there's the log of debug console.

console-log.txt

Share this post


Link to post
Share on other sites

Set
-i 0
0  (zero) = autoselect , just to eliminate that as a problem.

I also found this command:
disable X-Long-Polling support
--no-longpoll

I'm not sure if it needs a device id, ie, 0 or 1 in your case  or if the commands will even work. It's from CCminer (Nvidea)
By which I mean --no-longpoll 0

 

Also these

--no-gbt disable getblocktemplate support (height check in solo)
--no-stratum disable X-Stratum support

Edited by Rakly3

Share this post


Link to post
Share on other sites
On 7/20/2018 at 9:45 PM, Rakly3 said:

Set
-i 0
0  (zero) = autoselect , just to eliminate that as a problem.

I also found this command:
disable X-Long-Polling support
--no-longpoll

I'm not sure if it needs a device id, ie, 0 or 1 in your case  or if the commands will even work. It's from CCminer (Nvidea)
By which I mean --no-longpoll 0

 

Also these

--no-gbt disable getblocktemplate support (height check in solo)
--no-stratum disable X-Stratum support

Thanks for the support.

Tried with --no-longpoll it starts but hashrate remains to 0.0 KH/s.

This is what I'm getting:

Cattura.PNG.348e8968a8abeef8dadeafc127a87527.PNG

Share this post


Link to post
Share on other sites
11 hours ago, Metasploit said:

Thanks for the support.

Tried with --no-longpoll it starts but hashrate remains to 0.0 KH/s.

This is what I'm getting:

Cattura.PNG.348e8968a8abeef8dadeafc127a87527.PNG

I got same issue &  report in other post,seek someone can help on this

Share this post


Link to post
Share on other sites
On 7/24/2018 at 9:44 PM, Metasploit said:

Thanks for the support.

Tried with --no-longpoll it starts but hashrate remains to 0.0 KH/s.

This is what I'm getting:

Cattura.PNG.348e8968a8abeef8dadeafc127a87527.PNG

--gpu-platform 1
setting 1 is only for systems with intel gfx and AMD cards. All others should either not use it or use setting (minus one) -1
For a simple test make a .bat file with
sgminer --gpu-platform 1 -n
pause

Kinda hard to troubleshoot now, cuz now my miner doesn't find pool anymore and also have a dead rig. /sigh

EDIT, no wait, that's for sgminer, not claymore. Maybe it works on both...

Edited by Rakly3

Share this post


Link to post
Share on other sites
21 hours ago, Rakly3 said:

--gpu-platform 1
setting 1 is only for systems with intel gfx and AMD cards. All others should either not use it or use setting (minus one) -1
For a simple test make a .bat file with
sgminer --gpu-platform 1 -n
pause

Kinda hard to troubleshoot now, cuz now my miner doesn't find pool anymore and also have a dead rig. /sigh

EDIT, no wait, that's for sgminer, not claymore. Maybe it works on both...

This is what I'm getting with command:

nsgminer --gpu-platform 1 -n

Cattura.PNG.9553685dc1bf9709e3e0185ed9b15dba.PNG

Thanks for your support.

Share this post


Link to post
Share on other sites

Ah yup, your AMD is on platform 1 device 0

so you have to add --gpu-platform 1 in your launch commands.
That way it skips your igfx

Added it to the OP.

 

btw found a pretty neat website
https://coinguides.org/solo-mining-guide/
I'm trying to set up a VPS pool, but it's really difficult (never done it before)

Edited by Rakly3
  • Thanks 1

Share this post


Link to post
Share on other sites
14 hours ago, Rakly3 said:

Ah yup, your AMD is on platform 1 device 0

so you have to add --gpu-platform 1 in your launch commands.
That way it skips your igfx

Added it to the OP.

 

btw found a pretty neat website
https://coinguides.org/solo-mining-guide/
I'm trying to set up a VPS pool, but it's really difficult (never done it before)

Thanks for the support man.

Just tried but no luck.

I'll wait for pool mining.

Anyway thanks again.

Share this post


Link to post
Share on other sites

BTW I found why my miner didn't work any more. Maybe you have the same problem.

Every time you luanch the xaya-electron app, it generates a new password. I tried making it a fixed one, but it doesn't work (yet).
Also make sure your xaya-electron app is up, connected and synced. The daemon has to be running. Before you start you miner.
As you can see in my screenshot, I set the data dir override to a much easier to find directory (my documents). Now the .cookie file is there every time I run the app.

image.thumb.png.8a3571a6e688e31d0a9aa5574f4350ad.png

I noticed it when I was running the standalone deamon.
You can't run the daemon that launches with the app and the standalone together (on the same port)

image.thumb.png.8893a4f4a78c13160b3d3d61e87b09e7.png

 

BTW, can you check in your miner's folder there is a neoscrypt.cl file?
If not, you'll have to get it.

Edited by Rakly3

Share this post


Link to post
Share on other sites

this is what my nsgminer.conf after I let the miner generate a config file with default settings. (Don't use your .bat file if you want to use the .conf file. simply run the miner .exe itself)
It's basically a json file

 

{
"pools" : [
    {
        "url" : "http://127.0.0.1:8396/wallet/game.dat",
        "user" : "__cookie__",
        "pass" : "1593eebb3cc9625873eb818b9b765069990daa8c0e55f249da1af35a47e61c03",
        "pool-priority" : "0"
    }
]
,
"temp-cutoff" : "95",
"temp-target" : "90",
"intensity" : "d",
"vectors" : "1",
"worksize" : "128",
"kernel" : "neoscrypt",
"gpu-engine" : "0-0",
"gpu-fan" : "0-85",
"gpu-memclock" : "0",
"gpu-memdiff" : "0",
"gpu-powertune" : "0",
"gpu-vddc" : "0.000",
"temp-overheat" : "85",
"neoscrypt" : true,
"api-port" : "4028",
"expiry" : "120",
"expiry-lp" : "3600",
"gpu-dyninterval" : "7",
"gpu-platform" : "0",
"gpu-threads" : "1",
"log" : "5",
"no-pool-disable" : true,
"queue" : "1",
"scan-time" : "60",
"skip-security-checks" : "0",
"submit-stale" : true,
"temp-hysteresis" : "3",
"shares" : "0",
"kernel-path" : "/usr/local/bin",
"disable-gpu" : false
}

Edited by Rakly3

Share this post


Link to post
Share on other sites
3 hours ago, Metasploit said:

Thanks for the support man.

Just tried but no luck.

I'll wait for pool mining.

Anyway thanks again.

I found a package that worked straight out of the box here.

https://cryptomining-blog.com/3715-new-cgminer-3-7-8-with-improved-neoscrypt-performance/

Extract and edit the START-AMD.BAT
To start set --intensity (or -I) to 8.  You can change it later once you have everything up and running.)
Don't mind the no longpoll warning, It will take a couple of seconds per GPU before the mining starts. It's compiling the .bin files for your GPU.

As a reminder, every time you launch xaya-electron you have to set the new password from the .cookie file. Don't have the .cookie file open while launching the app.

If your PC locks up after a bit, we're gonna have to set some throttling parameters with a .conf file

Edited by Rakly3
  • Thanks 1

Share this post


Link to post
Share on other sites
On 7/31/2018 at 11:59 PM, Rakly3 said:

I found a package that worked straight out of the box here.

https://cryptomining-blog.com/3715-new-cgminer-3-7-8-with-improved-neoscrypt-performance/

Extract and edit the START-AMD.BAT
To start set --intensity (or -I) to 8.  You can change it later once you have everything up and running.)
Don't mind the no longpoll warning, It will take a couple of seconds per GPU before the mining starts. It's compiling the .bin files for your GPU.

As a reminder, every time you launch xaya-electron you have to set the new password from the .cookie file. Don't have the .cookie file open while launching the app.

If your PC locks up after a bit, we're gonna have to set some throttling parameters with a .conf file

It's WORKING!!

Thanks for your support.

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Your use of this site is governed by our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.